Jump to content
Sim Monsters

Recommended Posts

Give it some time, it is happening.

ya lol im just really excited for 4.5

Share this post


Link to post
Share on other sites

I finally got .37 to install -- even though it warned it would remove .39.5, this time it didn't. Some thoughts:

It works, but not well. Performance and graphics are terrible. The GUI is an eyesore, and the menu relying on the mouse only to select content is a pain to navigate. I ran a test using the same truck and track for .37, .39.5, and .4.5.1 using the same graphics settings. Here are the average FPS I got (for a fairly demanding track of mine):

  • .37: 73 FPS
  • .39.5: 89 FPS
  • .4.5.1: 125 FPS

This is a massive difference. .37 could not handle parts of the track with high-vert crush cars without dropping to around 50 FPS. While .39.5 and 4.5.1 also slow down, it's not noticeable and doesn't hamper playability. And the truck I'm using only has around 50,000 verts (which is about 100,000 less than some of the newer trucks here).

Appearance-wise things look off (originally made this content for .38+ so this isn't too surprising). However, trucks load correctly proving that if a truck is coded and packaged properly to be completely standalone, it will be compatible with ALL versions or RoR. Older content (like the V4 pack) either has incomplete material files or missing files resulting in errors. Simple as that.

Physics-wise, everything is the same -- even the speed. Some here have mentioned a 10 MPH difference but I'm not getting it. The ONLY difference I feel in the physics is the braking -- my trucks have anti-lock brakes, which do not seem to work in .37 as the trucks stop in a very harsh manner resulting in violent crashes.

In conclusion, .37 is vastly inferior to any newer version in every way. Some have mentioned it's better for online playing, but the performance has to be god-awful because using it in single player mode it quite a chore (and somewhat of an eyesore).

Share this post


Link to post
Share on other sites

I have a 7mph difference between 37 and 4.5 in first gear and a 2 mph difference in second. Dunno what that is about but honestly the speeds need to be reeled back to be more correct (waiting for confirmation from a driver for a more generic top speed per gear number). Which is fine as I have full intentions on producing a useable base be it Box5's or my own. The only thing left for me is to have a couple of fun runs to get accustomed to it (incase there are any quirks) but I am 99% sure that SMRA will be using 4.5 for the upcoming season. 

Edited by Outlawed
  • Upvote 2

Share this post


Link to post
Share on other sites

Regarding the speed, .37 only shows the "car speed", while .4.5 shows "wheel" and "car speed". For me, the car speed in .37 matches the wheel speed in .4.5., but the car speed is 3 MPH slower.

However, I believe they are actually moving at the same speed because I've compared jump results in both versions using the same truck/track combo, and they both land in the same spot every time.

Share this post


Link to post
Share on other sites
21 hours ago, Discorded_Official said:

I'm having a problem in 4.5 with everything being in fog, I don't know how to fix it or etc... just seeing if anybody can help

Raise the draw distance/visibility range to something over 300.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×